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About this reference 
  

This is the main Help reference for the course developer using this program. 
  
   

In this Help system, bright blue text is generally a cross-reference link (called a 
hyperlink) to another Help page. When you move the mouse pointer over it, the text will 

become underlined. 
 

 Text that has a light blue background like this Edit > Copy refers to a text menu operation 
in the program. Many of the commands in the text menus also have menu buttons such as 

the following: 
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Course Catalog 
The first window you will see when you open Design-a-Course Developer is the following 
Catalog View: 

               

  1. What is the Course Catalog? 
The Course Catalog is a "command center" for operations that involve entire courses. 
The following options are available from the Catalog View window: 

• Create a new course 
• Open a course from the catalog 
• Import a course into the catalog 
• Export a copy of a course 
• Delete a course from the catalog 
• manage Themes and Templates 
• select course  Preferences 

  2. Opening the Course Catalog 
The Catalog View will be the first window you will see upon opening the program. 
To return from editing a course back to the Course Catalog window, click the Catalog 
button  

                                             
 or use the text menu: Course > Catalog 

  3.  Creating a new course 
The Create New Course function allows you to begin a new course and set the properties 
for the course. When you create a new course, the program makes a new folder on your 
hard drive where all files associated with the course will be stored. 
  
1. From the Catalog View, select Create New Course. 
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2. You will see the following window. Enter course information and select Next.  

 
  
NOTE: 

Information entered into the Course Title field will be the name students see when they take 
the course online. The Directory Name field will be the name of the folder where your course 
files are stored. Version numbers are important as you create and upload updated versions of 
your courses. 

  
3. You will see the following window: 
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From this screen you will select the Theme for your course. A theme is a design strategy—
a particular “look and feel” you can use for your courses. Design-a-Course comes with a 
selection of default themes, or you may design your own themes. Refer to Themes and 
Templates for instructions on designing themes. 
Click Next. 
  
4. You will see the following window. Student Options refers to what students will be able 
to view as they take the course.  Enter Student Options and select Next. 

 
NOTE: Here you will select how many times students may attempt the questions within the course and 
what scoring and course information they can view. Students may view the course material 
indefinitely, even if they were given permission to take the questions only once. Maximum Times 
Student Can Take Questions refers specifically to the number of times students may take quizzes/tests 
and how many times the system will track those attempts. 

  
5. You will see the following screen. Questions information here refers to how and when 
quizzes will be given to students. Enter Questions properties and select Next. 

     
6. You will see the following window. Enter Course Prompt and Quiz Prompt properties 
on the Introduction Screens window: 
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NOTE: Select Show Course Prompt Page and/or Show Quiz Prompt Page if you wish to use the 
program's default prompts. Select the Customize options if you wish to design your own prompt pages.

  
7. Select Next. You will see the following window: 

        
Select Finish.  

  4.  Naming a new course 
When you create a course, the course title your students will see when they take the course 
online will be whatever you enter into the Course Title field on the course information 
window (pictured below). The name you give to the directory will be the name of the 
folder where all of the files associated with the course are stored.  
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If you wish to rename a course at any time, click on the course title in the Outline View, 
then click on the Properties button 
  

 
  

The Course Properties window will appear. You can change the name of your course in 
the Course Title field: 
  

 

  5. Importing a course 
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Importing allows you to bring courses into Design-a-Course quickly and easily. This can 
be useful when you are collaborating on courses with other developers. You can export the 
course to share, and then use the import feature to place the course back into your course 
folders. 
NOTE: 

If you are using a custom design template, the course will open with the Blank Theme when it is 
imported into another user's computer. 

  
To be imported, a course must be in .zip file format. 
To import a course, do the following: 

1. Click the Import Course button: 
 

 
2. The program will open to the Backup folder, pictured below. If the course you wish to 

import is stored in your Backup folder, click on the course .zip file and then click Import. 
If the course .zip file is in another directory, browse to that directory and click Import to 

bring the course into the Backup folder. 
 

 
 
   

  6. Exporting a course 
Exporting means saving a copy of your course. This can be useful during course 
development if you are collaborating on a course and need to share files or if you want to 
create a backup of your course. 
To export a course, do the following: 

1. Select the title of the course you wish to select from the Catalog View and click the 
Export Course button. 
 

     
2. The program will direct you to your Backup folder. You will see the window pictured 

below: 
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NOTE: 
The default file type for exporting is a .zip file. If you wish to export as some other type of file, use the 
Files of Type drop-down menu and select All Files. 

Click Export. The .zip file will be saved into your Backup folder. 

  7. What happens when a course is created? 
• The program makes a new folder on the hard drive. All of the files that become 

associated with the course are copied to this folder. The new folder appears under the 
Design-a-Course folder. The name of this new folder is the one that was typed in for the 
Directory Name when you created the course. 

• The program copies the default set of files that go with every course to that folder. 

  8.  Deleting a course 
The Delete Course function enables you to delete the course folder and all associated files 
from the Design-a-Course folder.  
  
1. Select the Delete Course button. 

           
2. Select Yes when the "Are you sure you want to permanently delete the selected course?" 
message opens up: 

 
  
Course is deleted. 
NOTE: 

Course files and folders deleted in this way are not recoverable from your 
recycle bin. However, if there is a backup of the course it can be restored using 
the Import feature of the program. 
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Chapter and text pages 
1. The difference between a chapter page and a text page 
The difference between a Chapter Page and a Text Page is primarily location — the 
program will treat any first-level text page as a chapter page in determining when and how 
to present the test questions to the student. Use chapter-level pages to indicate main topics 
within your course. 

2.Changing page levels 
Select the page to move by highlighting it in the outline. Any subpages it has will be 
moved with it. Use the active navigation buttons to move the page 

  
Active:  

 
  

Inactive: 
 

  

or use the text menu: Page > [Move Up/Down/Left/Right] 
Whether or not a direction arrow is active for any given page depends on that page's 
current level. For example, chapter page can only move up, down, or to the right because 
it is already at the top page level. 
To edit the text on a chapter or text page, see Text Editing 

Pages may also be moved with Keyboard shortcuts 

3. Adding pages to your course 
1. Click the Add Page button 

                                       
or use the text menu: Page > Add 
You will see the following window: 
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2. Fill in a title for the page in the space provided. Whatever name you assign the page 
here is the title that will appear in the outline. 
3. Under Add From, select Create New Page unless you have a pre-existing HTML page 
you wish to import into the course, in which case you will select Any Existing HTML Page 
and browse to that page to insert it. You may name the file here in the space provided, if 
you wish, or use the default filename, which is numeric and based on order of page 
creation. 
NOTE: 

The steps for adding a text page and adding a question page are not identical. Please go to the Question 
pages section for exact illustration of how to add a question page. 

  
4. Under Page Location, select from these three options:  

• Add After Current Page 

• Add as a Subpage 

• Add New Chapter 

NOTE: 
If the page you are adding is the first new page in the course, the only option you will have for Page 
Location is Add A New Chapter. 
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5. Select Next. If you are using the Blank Theme and haven't saved any template pages to 
it, you will go directly to the following window: 
 
 

     
6a. Select Finish to create the page. You will see it appear in your course outline.  
  
If you are using any other theme, you will see the following window: 
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6b. Select the type of page you wish to add (Chapter or Text) and click Next. You will then 
see the Page Complete window.  Click Finish and the page will appear in your outline. 
  

4. Deleting pages from your course 
To delete pages from your course, select the page to be deleted and click on the Delete 
Page button 

               
or use the text menu: Page > Delete 

This will bring up the DeletePage window.  

                                                          
Selecting Outline Only will delete your selected page from your outline, but it the 
underlying HTML page will remain in your course folder. Selecting Outline and Disk will 
remove the page from your outline and from your course folder.  Selecting Cancel will 
cancel the action. 
NOTE:   

When you delete a page that has subpages, the subpages are deleted as well. Once deleted, pages 
cannot be recovered. 

5. Changing the title of a chapter or text page 
In the Outline, select the page you want and click the Attributes button 

                                                  
or use the text menu: Page > Attributes 

You will see the following window: 
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To change the page title, type the new title into the Title space and then click OK. 
  
NOTE: 

This will change the name of the page in the outline, but it will not alter the name of 
the underlying HTML file. In order to change the file name as well, type the new 
name into the Filename space, then click OK. 

  

6. What happens when a chapter/text page is added? 
When you add a page, the following two things occur: 

• The program creates an HTML page in course folder (or if you are adding an existing 
HTML page to your course, this page is copied into your course folder). 

• The page entry is added to the XML file and the file name numbering index increases by 
one. 

  

7. What happens when a chapter/text page is deleted? 
When you delete a page, the program asks if you wish to delete the underlying HTML file. 
If you are certain you no longer want this page/file, select Yes when the Confirm Delete 
window appears.  This will delete the page entry from the XML file and from the course 
outline. If you wish to delete the page from the outline only but retain the HTML file, 
select No and the page will remain in your course directory.  
If a page has any subpages, those will be deleted along with it. 
  
NOTE: 

Once deleted, pages cannot be recovered. 
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Color settings 
          

NOTE: 
All color settings affect only the current page. Each page's color settings will need to be set 
individually. However, if you are creating a template, you can save any page and its design features 
(font color/size/position, background, graphics) as a template file, and those elements will be 
reproduced each time you use the corresponding template page. 

  

1. Selecting page background color 
To select or change the background color of the  current page, click the Page Color button    
                               
or use the text menu: Edit > Page Color 
Selecting PageColor brings up a selection of preset colors you may choose from.  Click 
Page ColorAdvanced to define a custom color from the screen pictured below. 

 
  

Choosing Page Image enables you to apply a graphic as a page background image. 
NOTE: 

If you are defining your own custom colors, the colors you select will remain on the "Recent" palette 
(see above) for convenient reuse.  

2. Selecting background image 
You can easily insert images into pages to be displayed as the page background. To add a 
background image, use the Page Color selection button  
                                  
or use the text menu Edit > Page Background 

From here, browse to the image of your choice and click open to insert the image as your 
page background. 
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3. Selecting text color 
Select the text to modify. Then choose one of the following options: 

• Click the Text Color Selection button:  
 
                      
 then choose from any of the preset colors or define a custom color with Text Color 
Advanced. 

• Text color may also be accessed through the drop-down menu: Text > Color . This will 
bring up the standard color window. Custom colors may be defined from this screen by 

selecting the swatches and then defining the color using the HSB and RGB tabs. 
 
 
 

 
 

 Use these same steps to change hyperlink and hotspot text color as well. 
  

NOTE: 
If you are defining your own custom colors, the colors you select will remain on the "Recent" palette 
(see above) for convenient reuse.  

4. Selecting table cell color 
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To add color or background images to table cells, click inside the cell you are changing (cells 
must be changed one at a time) and use the drop down menu Table > Table Cell > [Background 
Color/Background Image] 

5. Removing color selections or backgrounds 
The Font Color selection menu, the Page Color selection menu, and the Table Cell Color 
menu each have a "Remove Color" or "Remove Background" function which can be used 
to restore the default font and background values. 
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Glossary 
1. What is the course Glossary? 
The Glossary for a given course is a user-defined mini-dictionary with terms and 
definitions. Students can view the definitions while taking the course. 

                       
Online Glossary Window 

2. Opening the Glossary 
Click the Glossary button  

       
or use the text menu: Course > Glossary 

3. Adding a Glossary entry 
1. Click the Glossary button  

 

                 
 
 or use the text menu: Course > Glossary 
 
 You will see the following window: 
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2. Click on the Add button. You will see the following window: 
 

       
  

3. Type in the glossary word and click OK. This will add the term in the left-hand side of 
the glossary window. 

4. Highlight the text "Enter definition here" and type in your definition, replacing this text.  
5. Click on Close. Your entry will be saved. 

 
   

NOTE: 
Subsequent items may be added to the glossary without closing the glossary window. Simply follow 
steps 2, 3 and 4 above for each new entry until all entries are added, then close the glossary. 

  

4. What can be in the Glossary 
Just about any word, term, or phrase may be added — special characters are also allowed, 
but they must be copied and pasted from another program, such as Windows Character 
Map or a word processing software. 

5. Changing a Glossary entry 
1. Click the Glossary button  

 

                       
 
 or use the text menu: Course > Glossary 
   

2. Select the entry you wish to change from the left-hand column.  
  

3. Click inside the right-hand column where the definition appears and edit as you wish.  
  

4. Click Close to close the Glossary window. The changes you have made to your definition 
will be saved automatically. 

  

6. Adding special characters to a Glossary entry 
Use Character Map: a utility that comes with Microsoft Windows. Select, copy, and paste 
the characters as desired. 

7. Renaming/ Removing a Glossary entry 
1. Click the Glossary button  
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 or use the text menu: Course > Glossary 
   

2. Select the entry you wish to delete from the left-hand column. 
  

3. Click the Remove button. 
  

4. Click Close to close the Glossary window. 
NOTE: 

Deleted glossary entries cannot be recovered. Just add the phrase and definition again. 
  

To Rename a glossary entry, highlight the word you wish to rename, click the Rename 
button, and type the new name into the Rename Word window. 
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Hotspots 
To set the colors of hotspot text links, see Color settings. 

1. What is a Hotspot? 
A Hotspot is a link to another page in the current course. The link can be text or a picture 
file. 

2. Inserting a Hotspot 
1. Highlight the text or image you want to make into a hotspot. 

  
2. Click the Hotspot button 

 

           
 
 or use the text menu: Edit > Insert > Hotspot or Multi-media > Insert > Hotspot 
 
  

3. Select the destination page from the hotspot destination window. 
 

  
  

4. Click OK.  

3. Changing or Deleting a Hotspot 
1. Select the hotspot text or image on the page. 

  
2. Use the Hotspot button  
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 or the text menu: Edit > Insert > Hotspot to open the hotspot destination window. 

3. Change the destination by selecting another page or 
 Delete the destination by clicking the Select None button. 
  

4. Click OK. 
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Hyperlinks 
1. What is a Hyperlink? 
A Hyperlink is a selectable connection from one word, picture, or information object to 
another.  The most common form of hyperlink is the highlighted word or picture that can 
be selected by the user (with a mouse or in some other fashion), resulting in the immediate 
delivery and view of another object (often this is a page on some other Web site). 

2. Inserting a Hyperlink 
1. Select the item (text, picture) you wish to make the hyperlink and click the Insert 

Hyperlink button 
 
                          
 or use the text menu: Text > Hyperlink or Multi-media > Insert > Hyperlink. You may 
also bring up the Insert Hyperlink window with the keyboard command Ctrl + L. 

2. Select the type of link you are adding: Web link, FTP link, e-mail link, Newsgroup, or a 
relative link. 
   

3. Fill in the URL (address) information. 
  

4. Click OK. 
NOTE: 

If you select the incorrect type of link to be inserted (for example, you select Web but then enter an e-
mail address), you will receive an error message. 

3. Changing a Hyperlink 
1. Select the hyperlink. 

  
2. Use the Insert Hyperlink button  

 
                    
 or the text menu selections Text > Hyperlink or the keyboard command Ctrl + L. 
   

3. Change the URL as desired. 
  

4. Click OK. 

4. Removing a Hyperlink 
1. Select the text or object with the hyperlink. 
2. Click on the Insert Hyperlink button to remove the hyperlink 

 
                        
 or use the text menu: Text > Hyperlink and then un-check the hyperlink box on the text 
menu to remove the hyperlink. 
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Import/Export 
1. Importing 
Importing allows you to bring courses into Design-a-Course quickly and easily. This can 
be useful again when you are collaborating on courses with other developers. You can 
export the course to share, and then use the import feature to place the course back into 
your course folders. 
NOTE: 

If you are using a custom design template, the course will open with the Blank Theme when it is 
imported into another user's computer. 

  
To be imported, a course must be in .zip file format. 
To import a course, do the following: 

1. Click the Import Course button: 
 

                          
2. Select the .zip file of the course you wish to import using the Import Course window 

pictured below: 
 

   
3. Click Import. 
4. The program returns to the Catalog View, and you will see the imported course's title as a 

selection in your list of courses. 

2. Exporting 
Exporting means saving a compressed copy of your course. This can be useful during 
course development if you are collaborating on a course and need to share files or if you 
want to create a backup of your course. 
To export a course, do the following: 

1. Select the title of the course you wish to select from the Catalog View and click the 
Export Course button. 
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2. The default folder for exported courses is the Backup folder. Click on Export and a .zip 
copy of the course will be saved to the Backup folder 
 

           
  

NOTE: 
The default file type for exporting is a .zip file. If you wish to export as some other type of file, use the 
Files of Type drop-down menu and select All Files. 

  

3. Importing PowerPoint slides into Design-a-Course 
1) Open/Create a PowerPoint slide or presentation. 
2) In PowerPoint, select File > Save as Web Page then click the Publish button. This will 
open PowerPoint’s Save as Web Page window. 
3) Browse to your course directory. If you do not know the name of the course folder, 
open your course in Design-a-Course and click the Properties button. You will see the 
name of your course folder displayed in the Directory Name box. So, as an example, and 
using the default Design-a-Course installation directory, you want to save your files to 
“C:\Program Files\Design-a-Course\course_directory_name_goes_here”   
At this point you have 2 options: You can save the entire presentation where it will be 
presented to the student in the format of the sample below. NOTE: Below is just a sample 
from PowerPoint. Your course will reflect the look of your PPT presentation. 

 
As you can see, you will have the PP Slide and Outline displayed in a split page. Although 

 28



this allows the student to navigate within the presentation, DaC will see this as a single 
page in the outline. THIS OPTION IS NOT RECOMMENDED. 
To proceed with this method do the following: 
4) On the Publish as Web Page window, select Complete presentation under the Publish 
What? Section. 

                       
5) Click the Publish button. The entire presentation will be saved into your course 
directory as a single HTML page. 
6) With your course open in the Developer, click the Add Page button (or use the text 
menu Page > Add). 
7) Select Page Type and Page Location. Click Next. 
8) Browse to the file you added. Click Finish to add the page. 
  
The second option (PREFERRED) is to save each slide individually resulting in a course 
window that looks like this: 

          
To save in this manner, follow steps 1-3 above, then complete the following: 
4) Move your PPT slides into your course directory one at a time. On the Publish as Web 
Page window, select each slide number individually (Slide range 1 through 1) under the 
Publish What? Section. 

                        
5) Click the Publish button. The slide will be saved into your course directory as an 
HTML page. 
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6) With your course open in the Developer, click the Add Page button (or use the text 
menu Page > Add). 
7) Select Page Type and Page Location. Click Next. 
8) Browse to the file you added. Click Finish to add the page. 
NOTE: 

Often the Developer will not be able to read the imported PowerPoint slides, and you will see an error 
message that reads:  “This page is too complex to be edited from the Developer application. Choose 
Preview or Edit Externally from the page menu to view or modify the contents of the page.” When you 
choose Preview, you should be able to see your page as it will appear when published to the Web. If 
you wish to edit these pages, you will need to use an external editor. 
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Keyboard shortcuts  
Editor 
  

F10 Opens the Course menu 
Escape Returns you from a menu to the editing window 
Alt + A Opens Page Properties 
Alt + B Opens the Table menu 
Alt + C Opens the Course menu 
Alt + D Moves the selected page down 
Alt + E Open the Edit menu 
Alt + G Opens the Paragraph menu 
Alt + H Opens the Help menu 
Alt + L Moves selected page to the left 
Alt + O Open the Options menu 
Alt + P Opens the Page menu 
Alt + R Moves selected page to the right 
Alt + T Opens the Text menu 
Alt + U  Opens the Upload menu 
Ctrl + A Select all contents of page 
Ctrl + B Toggle bold text 
Ctrl + C COPY selection to clipboard 
Ctrl + H Backspace 
Ctrl + I Toggle italicized text 
Ctrl + L Hyperlink window 
Ctrl + S Saves your work 
Ctrl + T Increase indent (left text margin) 
Ctrl + U Toggle underlined text 
Ctrl + V PASTE selection from clipboard 
Ctrl + X CUT selection to clipboard 
Ctrl + Y Redo 
Ctrl + Z Undo 
Ctrl + Shift + T Decrease indent (left text margin) 
Shift + Ctrl+Page 
Down 

Select all the text from the cursor up to the top of the document 

Shift + End Select all the text from the cursor up to the end of the document 
Shift + Left or Right 
Arrow 

Select text, one character at a time, from the cursor to the left or right 

Shift + Up or Down 
Arrow  

Select text, one row at a time, from the cursor up or down 

Shift + Home Highlight from current position to beginning of line 
Shift + End Highlight from current position to end of line 
Shift + Enter Inserts a line break 
Shift + Spacebar Inserts a nonbreaking space 
Ctrl + Left Arrow Moves cursor one word left at a time 
Ctrl + Right Arrow Moves cursor right one word at a time 
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Ctrl + Home Move to the top of the page 
Ctrl + End Move to the bottom of the page 
End Goes to the end of the current line 
Home Goes to the beginning of the current line 
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Movie Files 
NOTE: 

Remember as you consider using movie files in your courses that very large files can cause noticeable 
lag time for your students as they wait for the files to download. 

1. Inserting Movie files 
The following movie file formats may be used in Design-a-Course: 

• MPG, AVI, MOV 

To insert a video file into your course page: 
1. With nothing selected, put the cursor at the insertion location and click the Movie button 

 

       
 or use the text menu: Multi-media > Insert > Movie 

2. Browse to the location of the file you wish to insert. 
3. Click Open to insert the file.  
4. After selecting the movie file you wish to insert and clicking Open, you will see the 

following screen:  

   
Here you will set your Video Options. The height and width refer to the size the movie 

will be online, measured in pixels. You have the option of allowing students to see the 
controls and decide when the movie will play. Other settings include options for when 
and how the movie will play.  

Once the movie file has been inserted, your page in the developer will show only a large 
movie camera icon. YOU WILL NOT SEE THE MOVIE IN THE DEVELOPER. 
However, if you click Preview, you will see what your students will see online.   
 
 Video Options can be accessed for editing through the text menu Multimedia > 
Properties. Click on the video file and then use the text menu to access the Video 
Options menu. 
 
  

NOTE:  
If something is selected on the page and a movie file is inserted, the movie file will overwrite and 
replace the selection. However, the item can be recovered with Undo. 
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2. Moving or Deleting Movie files 
Place your cursor in front of the movie camera icon on the page and press Delete. The file 
is recoverable with Undo. 
  
To move the location of a movie on a page, select the movie camera icon  and use the Left 
Align, Center, or Right Align buttons 

                                     
or place your cursor in front of the icon and use Tab, the space bar, or Enter to move the 
object on the page. 
NOTE: 

It is not possible to drag objects in order to move them within Design-a-Course.  
  
To delete a movie file, place your cursor before the movie icon and press Delete, or place 
your cursor behind the icon and press Back Space. Deleted items are recoverable with 
Undo. 
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Multimedia files 
See also: Audio (Sound) Files, Video (Movie) Files, and Pictures. 

1. What is a Multimedia File? 
A Multimedia file is a file that contains a picture, movie, or sound. 

2. Adding or inserting a Multimedia File 
1. With nothing selected, put the cursor at the location for the new multimedia file.  
2. Click the appropriate button  

 

 
 
 or use the text menu: Edit > Insert > [Picture/Movie/Sound] or Multi-media > Insert > 
[Movie/Sound] 
   

3. Browse to the location of the file to be inserted. 
  

4. Click Open to insert the file. 
  

NOTE: 
If something is selected on the page and a multimedia file is inserted, the icon for the multimedia file 
will overwrite and replace the selection. 

3. Moving, removing, or deleting a Multimedia File 
To move a multimedia element on a page, select the item to be moved and use the Left 
Align, Center, or Right Align buttons 

                                      
or place your cursor in front of the icon and use Tab, the space bar, or Enter to move the 
object on the page. 
To delete a multimedia file, place your cursor before the picture or icon and press Delete, 
or place your cursor behind the picture or icon and press Back Space. Deleted items are 
recoverable with Undo. 
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Outline 
Instructions on adding course pages (and information on what happens course pages are 
added and deleted) are covered in the Help screens that focus on the specific type of page: 
Chapter/text and Question. 

1. What is the Outline? 
The Outline shows how a course is organized in the program. Pages may be added, 
moved and deleted in the Outline. 
In addition, the Outline is your means of navigation within the Developer. Simply click on 
any page to go to that page. A sample outline is pictured below: 

 
  

2. Outline page levels 
For every course, the top of the Outline has an icon labeled with the Course Title. This 
page is not editable, and the program will not allow any other pages on the same level. 
Going from left to right, the page level number goes up. The Course Title icon is 
effectively at level 0. 
  

3. Moving a page in the Outline 
Select the page to move. Any subpages it has will be moved with it. Use the active 
navigation buttons to move the page 

  
Active:  

 
  

Inactive: 
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or use the text menu: Page > [Move Up/Down/Left/Right] 
Whether or not a direction arrow is active for any given page depends on its current page 
level. For example, a chapter page can only move up, down, or to the right because it is 
already at the highest page level. 
Pages may also be moved with Keyboard shortcuts. 

4. Removing or deleting a course page 
Select the page to delete. Caution: If it has any subpages, they will also be deleted. 
Click the Delete Page button  

             
or use the text menu: Page > Delete 
  
  
NOTE: 

Deleted pages are NOT recoverable with Undo. 
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Pictures 
1. Inserting Pictures in Design-a-Course 
To insert a picture file into your course page: 

1. With nothing selected, put the cursor at the location for the picture file and click the 
Picture button 
 

               
 or use the text menu: Edit > Insert > Picture 

2. Browse to the location of the file you wish to insert. 
3. Click Open to insert the file. Picture should appear on your page. 

 
  

NOTE:  
If something is selected on the page and a picture file is inserted, the picture file will overwrite and 
replace the selection. However, the item can be recovered with Undo. 

2. Moving Pictures 
Place your cursor in front of the picture on the page and press Delete. The file is 
recoverable with Undo. 
  
To move a picture on a page, select the picture to be moved and use the Left Align, Center, 
or Right Align buttons 

                                     
or place your cursor in front of the picture and use Tab, the space bar, or Enter to move 
the object on the page. 
NOTE: 

It is not possible to drag objects in order to move them within Design-a-Course.  

3. Resizing Pictures 
It is not currently possible to select a picture file and resize it within Design-a-Course 
Developer. If you need to resize a picture, you will need to do so in an outside program 
and then re-insert the file into the Developer. 

4. Deleting Pictures 
To delete a picture, place your cursor before the item to be deleted and press Delete, or 
place your cursor behind the item and press Back Space. Deleted items are recoverable 
with Undo. 

5. Suggested Picture file formats 
Supported Picture files formats include GIF, JPG, PNG. 
Different picture file formats are better for different things: 
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GIF Pros: good for line art and large flat 
fields of the same color, supports 
transparent backgrounds, animation and 
interlacing (where the resolution gets 
better as more of picture is displayed) 

Cons: limited to 256 colors, limited 
compression 

JPG  Pros: good for gradients and 
photographs (complex color patterns, 
fading and blending), millions of colors, 
higher compression 

Cons: no transparency or animation, only loads 
top to bottom, the more you compress — the 
lower the quality 

  
There are many Web sites that have a variety of picture files, both animated and non-
animated, that may be downloaded for free. 
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Preferences 
1. What are the Preferences? 
 Preferences refer to  

• Course Data (directory where the course is located and where the program looks to store 
new courses) 

• Editors (if you want to use an outside HTML editor to work on your course pages) 
• Preview Browsers (the browser/browsers you wish to preview your course pages in) 
• Spell Checker (the specific types of things you want the spell checker to look for). 

  

2. Setting Course Preferences 
From the Catalog View, click the Preferences button 

                                             
or use the text menu: Options > Preferences from the Outline View. 
You will see the following window: 

 
The application will pull up the list of files in your Design-a-Course Developer directory. 
You can use the drop-down menu to browse to a different location. 

» Course Data 

This feature allows you to change the directory you are working from. The application 
will pull up the list of files in your Design-a-Course Developer directory. You can use the 
drop-down menu to browse to a different location. 

» Editors 

The Editors tab enables you to select programs in which to edit your course pages 
externally. For example, if you wish to use an external HTML editor to adjust the HTML 
code on a page, you can select the editor of your choice from this screen and make it your 
default external editor.       
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NOTE: 
It is not mandatory that an outside editor be selected in order to use the Design-a-Course Developer. 
Some course builders may find that they want to work with the HTML code or do other, more complex 
procedures on their HTML pages and in this case, may choose to use an external editor. 

   
To select editors: 
1. Click on the Editors tab. You will see the following window: 

 
 

2. Click Add. You will see the following window: 
 

 
3. Type in the Name for the editor and the location in the Command space (if you know it) 
or click Browse to find the file. If you select Browse, you will see the following window: 

    
4. Browse to the file of your choice. The new editor will appear on the Editors tab main 
window.  
  
Selecting a default editor: 
Checking the box beside the editor and under the "Default" column will select that 
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program to open anytime you select Page —> Edit Externally from inside the Developer. 
Removing an editor: 
Select the editor from the list on the Editors tab main window and click Remove. 
Changing Name or Command line: 
1. Select the editor you wish to change from the list on the Editors tab main window. 
Name and command for the program selected will appear in their respective spaces. 
2. Make changes to the Name and/or Command line. 
3. Click Change button to save changes. 
  

» Preview Browsers 

  
The Preview Browsers tab allows you to set the browser of your choice for viewing your 
HTML pages as you build your course.  
NOTE: 

A default browser must be selected in order to preview pages. If a preview browser has not been 
selected, you will be prompted to select one the first time you attempt to use the preview function.  

  
To select a preview browser: 
1. Click on the Preview Browsers tab. You will see the following window: 

 
2. Click Add. You will see the following window: 

 
3. Type in the Name for the browser and the location in the Command space (if you know 
it) or click Browse to find the file. If you select Browse, you will see the following 
window: 
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4. Browse to the file of your choice. The new browser will appear on the Editors tab main 
window.  
Selecting a default browser: 
Checking the box beside the browser and under the "Default" column will select that 
program to open anytime you select Preview from inside the Developer. 
Removing a browser: 
Select the browser from the list on the Preview Browsers tab main window and click 
Remove. 
Changing Name or Command line: 
1. Select the browser you wish to change from the list on the Preview Browsers tab main 
window. Name and command for the program selected will appear in their respective 
spaces. 
2. Make changes to the Name and/or Command line. 
3. Click Change button to save changes. 
  

» Spell Checker 

The Spell Checker tab allows you to set the behavior of the Design-a-Course Developer's 
spell check function.  
To set the spell check behavior: 
1. Click on the Spell Checker tab. You will see the following window: 
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2. Select the behaviors you wish to set and click OK to save them. 
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Preview 
Use the Preview facility to see what the course page looks like in your selected browser. 
The first time you use preview, Preferences window, accessible through the Options > 
Preferences menu. 

1.  Using the Preview feature 
With the page open in the editor, click the Preview button  

                     
or use the text menu: Page> Preview 
  
NOTE: 
What is seen with Preview will not necessarily be what a student sees while taking the 
course. Size should be considered. The viewable space for text pages is 600 x 520, and for 
question pages it is slightly smaller, 600 x 410. 

  
In addition, if you have not yet set a browser to use for previews, you will receive a message 
telling you to set your default browser in the Application  Preferences. 
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Course Properties 
1. What are the Course Properties? 
The Course Properties are settings that determine how a course works and what the 
students can see and do in the course. The settings are stored in the XML file for the 
course. 

2. Setting Course Properties 
1. Highlight the course title in the outline. 
2. Click the Properties button 

             
        or use the text menu: Course > Properties 

You will see the following window: 

 
NOTE: 

Course properties can be changed at any time during development. Simply follow the steps above to 
access the Course Properties window. Then follow the steps below for the areas you wish to change. 

  

» The General tab 
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The Title field stores the name of the course as it should appear in the Course Catalog. 
The Directory Name is the name of the folder where the course files are stored.  
The Version number is important if changes are made to a course that will effect the 
tracking of scores (i.e., if the questions or question bank has changed). If the course is 
uploaded with the same version number after such revision, the database will still track the 
previous version. 
The Last Modified Date and Developed By fields are there for the developer’s benefit. 
Their content appears only on this page and does not affect the program. 

» The Theme tab 

 
The Theme field allows you to switch your themes during course development. Simply 
select from your list of themes, and all subsequent pages will have that theme applied to 
them when they are added. However, changing themes does not apply to pages already 
added under another theme. These will remain as they were when they were added. 

» The Options tab 
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Maximum Times a Student Can Take Questions — how many times the student can take 
the course questions for scoring purposes. This can be: 

• Unlimited 

• Limited (any number from 1 to 25) 
 
   

NOTE: 
Students may view the course material indefinitely, even if they were given 
permission to take the questions only once. Number of attempts refers specifically 
to the number of times students may take quizzes/tests and how many times the 
system will track those attempts.  

Allow Students To — what the students can do and see while taking the course. 
  

View Course Outline Students can view the course outline and go to 
any page in the course; they need not follow the 
normal sequence. 

View Their Score Students can view their test score after 
the last question has been answered. 

If quizzes appear at the end of each unit within 
a longer course, they will be given a cumulative 
score at the conclusion of each quiz. 

View Their Answers Students answers will be displayed along with 
the correct answers. 

Skip Questions 
  

Students can choose not to give an answer on a 
question page. This is useful if you want to limit 
the number of times students can be scored on 
questions, but you want to allow them to cover 
the material as much as they need to before 
being tested. 

» The Question tab 
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Have Students Take Questions — options for when and how the test questions are 
presented to the student: 
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Quiz Properties: 
Ask Questions in Random Order — only applicable for the latter two above, all of the 
questions are presented. 
Ask a Random Subset of the Question Pool — as above, but not all of the questions in the 
course are necessarily presented. 
Questions in Each Quiz — Applies to the number of question per quiz to be taken 
randomly from the question pool. 

» The Prompts tab 
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Prompt Pagesoffer students navigation and test taking information. The program has 
built-in prompt pages, or you can selectCustomize Course Prompt Page and/or Customize 
Quiz Prompt Page to build and edit supplemental, built-in help screens (rather than the 
ones that come with this program): 
  

SCREEN SUGGESTED CONTENTS 
Course Prompt Information on how to navigate the course, 

view the Outline (if applicable), run multimedia 
files (if applicable), and view glossary items 

Quiz Prompt Information on how to answer the different 
types of questions in the course 

   
When one or more boxes are checked, the corresponding pages will appear at the bottom 
of the Outline after the course is re-opened. Although the developer sees only the prompt 
pages at the bottom of the outline, the student will see the Course Prompt page at the 
beginning of the course, while the Quiz Prompt pages will appear at the beginning of any 
quiz or quizzes within the course. 
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Question pages 
To move or delete question pages, see Outline. 
To edit the text on a question page, see Text Editing. 
To set how the test questions should be presented in the course, use the Properties. 
All question page settings are stored in the XML file for the course. 

1. What is a Question page? 
A Question Page is a page that contains a question (typically as part of a test or quiz) for 
the student taking the course. 

2. Adding or inserting a Question page 
1. In the Outline, select the text page under which to add it, then click the Add Page button 

 

 
 or use the text menu: Page > Add. You will see the following window: 
 

 
   

2. Title the page (whatever you type here will be the name of the page in the outline). 
3. Select where the page will be added from: 

 
 Create a New Page—Creates a new HTML page. 
 Any Existing HTML Page—allows you to browse to an existing HTML page and add it 
into your course. You may name the file here in the space provided, if you wish, or use 
the default file name, which is numeric and based on order of page creation. 

4. Select Page Location: 
 
 Add After Current Page 
 Add a Subpage 
 Add a New Chapter 
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NOTE: 
The first page you add to a course must be a Chapter 
page. You will have no other options when adding 
your first page. This is because question pages are 
always subpages of text pages. 

Under Add As, select Question. 
Click Next. You will see the following window: 
 
 

 
Type in your question in the place provided. If you are building your outline before 
inserting content, you can leave this field blank and enter the question text directly onto 
the page later in development. 
Fill in the Search Keyword. The search keyword field is a place where you can put terms 
that will be searchable in the online database. For example, if a course 
instructor/administrator wanted to find all question in a particular course that dealt with a 
particular topic, he would be able to find them by using the topic as a Search Keyword. 
Using the Search Keyword field is not required. 
  
Click Next. You will see the following window: 
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 Select Question Type. 
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 Select the response you wish to give students once they answer the question. Your 
options are as follows: 
 a)Do Nothing—after the student submits the answer, the course will move on to the next 
question. 
 b)Further Explain the Answer—after the student submits the answer, they will be taken 
to a sub-page of the question where feedback can be given, depending on whether their 
answer was correct or incorrect.  
 c) Jump to a New Page—after students submit the answer, they are taken to a page you 
have specified within the course. Select the page you wish students to navigate to by 
highlighting it in the outline beside Jump to a New Page. 
 

 
 
  
NOTE: 

If you choose the Further Explain the Answer option, you will be directed through 
the creation of the sub-pages. 

Click Next. You will see the following page: 

 62



 
 
 This window summarizes the details of your new page and shows you a preview. Click 
Finish, and the new question page will appear in your outline. 

3. Setting the options for a Question page 
Select the page in the outline and click the Attributes button  

                                   
 
or use the text menu: Page > Attributes. You will see the following window: 
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» Page  
1. Highlight the page title in the outline. 
2. Click on the Attributes button 

 

 
 
 or use the text menu: Page > Attributes. You will see the following window: 
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3. Type Title in the designated space. 
4. Type Filename in designated space. 
5. Click OK. 

  
NOTE: 

If there is a pre-existing file that will be inserted here, browse to the file and insert. However, if the 
program is creating this page fresh for you, you can simply click OK and accept the default filename. 

  

» Question details 

Question Details are the actual questions your students will see. Simply type in the 
question here as you want it to appear to the students. If you are developing the pages in 
your outline prior to inserting content, you can skip this for now and fill the questions in 
later. 
 
Search Keywords refers to words related to the question that will be searchable in the 
online database. For example, if the professor wanted to look up all questions in a 
particular course that had to do with, say, finance, he/she could enter "finance" as a search 
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keyword when building the course questions and then find those questions and their 
results by using that term for an online question search.  

                     

» Question types 

  
Click the tab for Question Type. You will see the following window: 
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  and select the type: True/False, Multiple Choice, Select All, Fill in the Blank. 
  

For the question type, enter the correct answers as appropriate. 
  

» Scoring options 

Click on the Scoring tab. You will see the following window: 

 
The Time Limit is how many seconds the student has to enter an answer to the question 
before it is automatically counted wrong. 
The weight determines the number of points the question is worth, compared to the other 
questions in the course. 
  
NOTE: 
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The total number of points for the course need not equal 100 — or any other specific number.  
» Explanation options 

After the student enters an answer to a question, a window can appear which contains text 
to explain or comment on a student’s correct or incorrect response. (Not valid for essay 
questions.) 

1. Click on the Correct Response tab or Incorrect Response tab as appropriate. You will see 
the following window: 

 
 

 
 
  

2. If you wish for no response to be given, click the Do Nothing option. If you wish to offer 
feedback, select the box for Further Explain the Answer. 

3. Click OK. 
 
 If you selected the Further Explain the Answer option, the program creates a new page 
for the explanation, and you will see a message like the following: 
 

 
  

4. Click OK to create the response page. 
5. Do the same thing for both correct and incorrect responses to each question. 

 
 
 Branching Options 
 
 Students may also be sent to another page within the course as reinforcement or 
feedback for an answer (called branching). The steps are as follows: 
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1. Click on the Correct Response tab or Incorrect Response tab as appropriate. 
2. Select the box for Jump to a New Page on (Correct/Incorrect) Answer. You will see 

the following window: 
 

 
 
  

3. Select the target page from the mini-outline. 

4. What happens when a Question page is created 
• The program makes a blank HTML page in the course folder.  
• The page entry (which includes the question page settings) is added to the XML file and 

the file name numbering index increases by one. 

5. What happens when a Question page is deleted 
When you delete a question page, the program asks if you wish to delete the underlying 
HTML file. If you are certain you no longer want this page/file, select Yes when the 
Confirm Delete window appears.  This will delete the question page entry from the XML 
file and from the course outline. If you wish to delete the question from the outline only 
but retain the HTML file, select No and the page will remain in your course directory.  
If the question page has any subpages, those will be deleted along with it. 
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Saving your work 
To save your work, click on the Save button 

                                                      
or use the text menu: Page > Save 
   
Moving to another page in the course after making changes to the page being worked on 
produces a Save Changes prompt: 
  

 
  

Once changes are saved to any page in this manner, Undo and Redo are no longer 
available to that page. 
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Sound Files 
1. Inserting Sound files 
The following sound file formats may be used in Design-a-Course: 
 AU, WAV, RMI, MID 

To insert a sound file into your course page: 
1. With nothing selected, put the cursor at the location for the file and click the Sound 

button 
 

 
 or use the text menu: Multi-media > Insert > Sound 

2. Browse to the location of the file you wish to insert. 
3. Click Open to insert the file.  
4. After selecting the sound file you wish to insert, you will see the following screen:  

  
Here you will set your Sound Options. The height and width refer to the size the sound 

player will be online, measured in pixels. If you do not wish for the player to be visible, 
uncheckShow User Controls. Other options include settings for when and how the 
sound will play. For example, you can choose not to show the control and have the 
sound play continuously  whenever a student opens that page.   
 
 Sound Options can be accessed for editing through the text menu Multimedia > 
Properties. Click on the sound file and then use the text menu to access the Sound 
Options menu. 
  

NOTE:  
If something is selected on the page and a sound file is inserted, the sound file will overwrite and 
replace the selection. However, the item can be recovered with Undo. 

2. Moving or Deleting Sound files 
Place your cursor in front of the sound file icon on the page and press Delete. The file is 
recoverable with Undo. 
  
To move the location of the sound control on a page, select the sound file icon and use the 
Left Align, Center, or Right Align buttons 

                                     

 71



or place your cursor in front of the icon and use Tab, the space bar, or Enter to move the 
object on the page. 
NOTE: 

It is not possible to drag objects in order to move them within Design-a-Course.  
  
To delete a sound file, place your cursor before the sound icon and press Delete, or place 
your cursor behind the icon and press Back Space. Deleted items are recoverable with 
Undo. 
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Spell Checker 
1. What is the Spell Checker? 
The Spell Checker checks the spelling of the text on the current page by comparing it 
against a Dictionary file.  
  
NOTE: 
Spell check must be performed separately on each page of the course. 

Also, the program cannot check any text that is embedded in a picture or movie file. 

2. What is the Dictionary? 
The Dictionary is a file with a very long list of words. The program is compatible with 
both UK and American English. 

3. Using the Spell Checker 
While editing a course page, click the Spell Checker button 

 
or use the text menu: Edit > Spell Check 

If the spell checker does not find any errors, this should appear: 

 
Otherwise, there are options regarding what to do with the text the spell checker does not 
recognize. 

» Ignore 

Click the Ignore button to leave this item as it is. The program will find the item again the 
next time the spell checker is run. 

» Change 

To change this item to something else: 
1. Scroll through list of choices until the correct word is found (each word appears in the 

Replace With window when it is highlighted). 
2. Click the Change button. 

» Ignore all 
Click the Ignore All button to leave this item as it is for the rest of the page. The program 
will find it again the next time the spell checker is run. 

» Change All 
To change this item and all occurrences of this item in the current page to something else: 
do the same as above for Change, but click the Change All button. 

» Cancel 
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Click the Cancel button to cancel Spell Check. 
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Tables 
1.  Inserting a table 
Place the cursor where the table should go and click the Table button 

                     
 or use the text menu: Edit > Insert > Table 

Choose the settings for the table, including the number of rows and columns. (For 
example, the table below has four rows and two columns.) 
  

 
  

Spacing  How much space between cells — in number of 
pixels (increases interior border thickness) 

Cell Padding  How much space inside the cell between the 
frame and the contents — in number of pixels 

Table Width How wide the table should be in number of 
pixels or percentage of the user’s screen width 

Visible Border Check this box if you want the border of your 
table to be visible. 

   
A table may also be put into the cell of an existing table. (One term for this is nesting.) 

2.  Previewing table before insertion 
To preview how your table will look after it is inserted on your page, use the Preview tab 
from the Insert Table screen, as shown below: 
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3.  Deleting a table 
Use the text menu Table > Delete Table.  Tables may also be deleted using the Delete 
Table Button 
 
                    
located above the Editor window. 
The table and its contents are recoverable with Undo. 

4. Inserting a row or a column 
To insert rows or columns, use the text menu: Table > [Insert Row Before/Insert Row 
After/ Insert Column Before/Insert Column After] 
  

 
  
Rows and columns can also be inserted with the Insert Row After button 

                  
and the Insert Column After button 

                  

5. Deleting a row or column 
Select a cell in the row or column to be deleted. 
Use the text menu:  Table > [Delete Row/Delete Column] 
Rows and columns may also be deleted using the Delete Row button 

                   
or the Delete Column button 
                  
The deleted rows/columns and their contents are recoverable with Undo. 
  

6. Table Editing Buttons 
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When working with tables, if you click inside any table cell the Table Editing Buttons will 
become active and available for table editing. The table below lists each of the buttons and 
its function: 

  
  Table Properties Button   Insert Row After Button 
   Insert Column After Button   Delete Row Button 
    Delete Column Button    Delete Table Button 
   Table Cell Color   

7. Changing Table Cell Color  
To change the background color of a table cell, use the text menu  
Table > Table Cell > [Background Image/Background Color]. This will only change one 
cell at a time, so you will need to repeat the process for each cell you wish to give a 
background color/image. 

8. Resizing columns 
To adjust your columns, first select the Unit (third column). This column is a drop-down 
menu which allows you to select either pixels or percent. Next, for each column click 
inside the Value column and type in the value you want each column to be. When you 
have completed the information, click OK. Your columns will resize to match your 
settings. 
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Text Editing 
With text already selected, setting changes will be applied only to that text. Otherwise, 
settings will be applied to whatever is typed. 
Standard editing features are accessible within the Developer through the right-click drop-
down menu. 

1. Selecting font 
To change your font selection, use the font selection drop-down menu 

 
or use the text menu: Text > Font  and you will see the following window: 

 

2. Selecting font size 
To change the size of your text, use the size selection drop-down menu 

 
or use the text menu: Text > Size 

NOTE: 
Text appears different in size in a browser window than it seems in the Developer environment. Use 
Preview to see how your font selections will appear online. 

3. Standard formatting features 
Standard text formatting and text editing features are also available on the toolbar 

 
     

and on the text menu:  
Edit —> Insert —>[Table/Picture/Movie/Sound/Hotspot] 
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Edit —> [Undo/Redo/Cut/Copy/Paste/Background Color/Spell Check] 
Multi-media > Insert [Movie/Sound/Hotspot/Hyperlink] 
Paragraph —> [Align/Unordered List/Ordered List/Indent/Outdent] 
  
Text —> [Bold/Italic/Underline/Color/Hyperlink] 
Text —> Size —>[Smallest/Smaller/Small/Normal/Large/Larger/Largest] 
Table —> [Properties/Delete Table/Insert Row Before/Insert Row After/Delete 
Row/Insert Column Before/Insert Column After/Delete Column] 
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Themes and Templates 
1. What are Themes and Templates? 
A theme is a design strategy—a particular “look and feel” you can use for your courses. 
Templates are individual pages within the theme, each designed for the particular kind of 
information it will include, for example, Chapter Introduction pages, Text pages, Question 
pages, Response/Feedback pages, etc. Themes are composed of a collection of template 
pages that all have the same “look and feel.” In other words, template pages in the same 
theme will share many of their images and other design features. 
You can create as many templates as you like for any given theme. You will be given a 
choice between the different templates you have added to a given theme when you add 
individual pages to your course. 
Design-a-Course comes with a collection of default themes that you may use for your 
courses. One of these default themes, called the Blank Theme, is the theme you will select 
to create your own theme and templates. If you wish to start with very basic page design, 
you may also select the Simple Theme to begin your own design. 

2. The Theme Manager 
The Theme Manager enables you to delete, rename, and copy your themes and to manage 
your templates. To access the Theme Manager, click on the Themes button from the 
Catalog View: 

                                                   
This will open the Theme Manager window, where you will see the themes currently 
available: 

  
  

To delete, rename, or copy any of your themes, highlight the theme name and click the 
button for the corresponding action. If you have chosen to rename or copy a theme, you 
will see the following window: 
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Simply type in the name for the theme and press OK. If you are copying the theme, you 
will see it appear in the theme list with the new name. If you are renaming the theme, you 
will see the new name appear in the list of themes. 
NOTE:  
DO NOT rename, delete, or modify the themes that come with Design-a-Course. If you wish to 
rename or modify one of the default themes, copy it first, then rename and save it for your 
modifications. This will ensure that you preserve the default themes for future use. 

Additionally, if you delete a theme from your theme manager, you will not be able to add additional 
pages to any course that was created using that theme. 

  

3. Creating a New Theme and Template Pages 
The first step in creating a new theme is to copy and rename an existing theme. If you 
wish to start with blank pages and incorporate your own design elements, then you should 
copy and rename the “Blank Theme,” which has no design or formatting built into it. If 
you wish to begin with simple page format elements built in, select the “Simple Theme” to 
copy and rename. If you wish, you may copy and rename any of the other default themes 
and modify them, but remember: DO NOT rename, delete, or modify the original default 
themes. 
To create a new theme:  
1. Click on the Themes button in Catalog View. 
 

                       
  
2. Click on Blank Theme in the Theme Manager window. 

                         
3. Click Copy/New… to make a copy of the Blank Theme. 
4. Name your new theme in the Input window and click OK. The theme name will appear 
in your list of theme choices. 
5. Click on the title of your new theme to highlight it then click on Manage Templates. 
You will see the following window: 
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What you see in this window is a list of the template pages included automatically in the 
theme you copied. If you wish to add a type of page not included in this list, copy one of 
the existing pages, name it appropriately for the type of page it will be (for example, 
Chapter Objectives), then click OK. You will see the new template type page name appear 
in this window. 
NOTE: 

Correct/Incorrect Answer Explanation and Course/Quiz Prompt pages each play a specific role within 
the program and cannot be renamed. If you choose to, you may customize the design of these pages to 
fit your theme, but they cannot be renamed. 

  
6. Click Close to close the Template Manager and Close again to close the Theme 
Manager.  
You have now created the foundation for a new theme. The next steps involve designing 
the template pages and saving them into your new theme. 

4. Creating Templates and Adding them to Your Theme 
1. Click the Create New Course button from the Catalog View: 

                    
2. Give the course and folder a name. Click Next. 
3. From the Theme selection window, click on the title of your new theme. 
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4. Complete the course setup as desired (see Creating a new course under Course Catalog 
for instructions on course setup options). 
You will see that you are now in the Outline View, in a new course with no pages added 
yet. 
5. Click the Add Page button: 

                                
       or select  Page > Add from the text menu. 
6. Title the page.  
7. Use any of the editing features (text size/color, background image/color, etc.) to add 
design your page as you wish it to appear. Remember, there can be templates for different 
page types, but generally you will want to keep design features similar and coordinated 
within themes. 
8. Once you are happy with the design of your page, use the text menu Page > Save as 
Template. You will see the following window: 
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9. If you wish to overwrite one of the default template pages, select it from the list and 
click OK. NOTE: THIS CAN NOT BE UNDONE. 
10. If the type of page you wish to add is not available from the list: 

1. Select New Template 

2. Type a name for the new template page 

3. Choose Text or Question Template 

4. Click OK. 
11. Repeat the steps above until you have designed and saved the template for each kind 
of page you wish to include in your theme. After you have designed and saved your 
template pages, all you need to do to reproduce the theme for additional courses is:  

1. Select the theme you wish to use when creating your course. 
2. Select the page type (Chapter, Text, Question, etc.) to be added when completing 
the Add Page process. 

NOTE: 
If you reuse any theme for subsequent courses, changes made to that theme will affect any previously 
developed course that shares the theme (if the earlier course is stored in the same course directory). If 
you wish to reuse a theme but wish to make changes that you do not wish to carry across to other 
courses using that theme, copy and rename the theme. Then, any changes you make will apply only to 
the courses using the modified theme. 
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Undo and Redo 
1. What are Undo and Redo? 
Undo allows returning the current page to a previous state before certain changes to it 
were made.  
With Redo, one may recover one or more Undo changes — after at least one Undo is 
performed. 
  
Moving to another page in the course after making changes to the page being worked on 
produces a Save Changes prompt: 
  

 
  

Once changes are saved to any page in this manner, Undo and Redo are no longer 
available to that page. 
  

2. Using the Undo feature 
While editing a course page, click the Undo button  
                   
                    
or use the text menu: Edit > Undo for every level of Undo. 

3. Using the Redo feature 
At least one level of Undo must be done first.  
Click the Redo button  
 
                 
 
or use the text menu: Edit > Redo 

4. What constitutes a "change" to the page? 
The program considers each of the following to constitute one "change" to the page: 

• Continuous text input into the body of a page 

• A single change in text or paragraph attributes: 
o font, color, size 

o bold, italic, underline, background 

o alignment, indent 
o change selection to/from list (bullet or number) 

o any of the above inside a single table cell 
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• Delete/move/re-size an item on a page 

• Insert a table 
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Upload course 
Use the Upload facility to send the course to the MindIQ servers for hosting. 

  1. Uploading a course to MindIQ 
1. Open the course and click the Upload button  
 

                       
 
or use the text menu: Course > Upload  
You will see the following window: 

 
  
2. Enter URL, user name, and password. 
3. Click OK. 
4. You will see the progress as the files upload. When the upload is successfully 
completed, you will get the following message: 

 
The Upload menu may also be accessed with Keyboard shortcuts. 
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